• Upgrading from 2.30 to 3.19b

    From Riba@VERT to alt.bbs.synchronet on Thu Jul 14 23:06:10 2022
    From Newsgroup: alt.bbs.synchronet

    Hey all!
    I used to run a Synchronet BBS from the early 1990s until 2003 when we finally pulled the plug. While cleaning out my place I found a CD with the backup taken at the time and it was still readable. I was also pleasantly surprised finding out that Rob has continued developing the software and now I'd like to bring the BBS back online for people who used to visit.
    I've been through docs but could not find the straightforward answer what would be the proper procedure to upgrade a 4-node MSDOS 2.30b SBBS to run under the current 3.19b version. I'm about to start tinkering, but any tips that would save me time and headache are welcome.
    I suspect it is not as simple as installing 3.19b over existing c:\sbbs directory or am I wrong?
    Thanks!
    Tom
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Fri Jul 15 10:20:17 2022
    Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Fri Jul 15 2022 01:06 am

    From Newsgroup: alt.bbs.synchronet

    Hey all!
    I used to run a Synchronet BBS from the early 1990s until 2003 when we finally pulled the plug. While cleaning out my place I found a CD with the backup taken at the time and it was still readable. I was also pleasantly surprised finding out that Rob has continued developing the software and now I'd like to bring the BBS back online for people who used to visit.

    Awesome. Welcome back!

    I've been through docs but could not find the straightforward answer what would be the proper procedure to upgrade a 4-node MSDOS 2.30b SBBS to run under the current 3.19b version. I'm about to start tinkering, but any tips that would save me time and headache are welcome.
    I suspect it is not as simple as installing 3.19b over existing c:\sbbs directory or am I wrong?
    Thanks!

    You're right: it's not quite that simple. :-)

    An install would overwrite your .cnf (configuratino) files in your ctrl and you probably don't want to do that. Custom text/menu files would be overwritten too.

    I'd go through the various sbup*.zip files in http://synchro.net/files/Main/SBBS_ARC/ and
    http://synchro.net/files/Main/SBBS/(starting with sbup300c.zip)

    And then finally (once you get to v3.19b), run 'jsexec update'.

    Hopefully that works for you (make/keep backups) and if you run into any problems, let us know and we'll help you out.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #79:
    Sysop = System Operator
    Norco, CA WX: 85.7F, 51.0% humidity, 8 mph SSE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Fri Jul 15 12:02:53 2022
    From Newsgroup: alt.bbs.synchronet

    On Friday, July 15, 2022 at 10:20:23 PM UTC+3, Digital Man wrote:
    You're right: it's not quite that simple. :-)

    An install would overwrite your .cnf (configuratino) files in your ctrl and you probably don't want to do that. Custom text/menu files would be overwritten too.

    I'd go through the various sbup*.zip files in http://synchro.net/files/Main/SBBS_ARC/ and
    http://synchro.net/files/Main/SBBS/(starting with sbup300c.zip)

    And then finally (once you get to v3.19b), run 'jsexec update'.

    Hopefully that works for you (make/keep backups) and if you run into any problems, let us know and we'll help you out.
    Fantastic, thanks!
    I considered moving the subs, user db and custom menus/screens from old SBBS to fresh 3.19 install, but wasn't sure there haven't been any changes in the format of these files. The route you proposed sounds much more sensible, I'll try it out and report back how it went.
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Fri Jul 15 13:40:50 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Fri Jul 15 2022 02:02 pm

    From Newsgroup: alt.bbs.synchronet

    On Friday, July 15, 2022 at 10:20:23 PM UTC+3, Digital Man wrote:
    You're right: it's not quite that simple. :-)

    An install would overwrite your .cnf (configuratino) files in your ctrl and you probably don't want to do that. Custom text/menu files would be overwritten too.

    I'd go through the various sbup*.zip files in http://synchro.net/files/Main/SBBS_ARC/ and http://synchro.net/files/Main/SBBS/(starting with sbup300c.zip)

    And then finally (once you get to v3.19b), run 'jsexec update'.

    Hopefully that works for you (make/keep backups) and if you run into any problems, let us know and we'll help you out.
    Fantastic, thanks!
    I considered moving the subs, user db and custom menus/screens from old SBBS to fresh 3.19 install, but wasn't sure there haven't been any changes in the format of these files.

    That method would mostly work too. Some of those sbup*.zip files contain readme's with important information, so I'd at least read those too.

    The route you proposed sounds much more sensible,
    I'll try it out and report back how it went.

    Cool. As long as you're making/keeping backups along the way, there's nothing to do lose.
    --
    digital man (rob)

    Rush quote #4:
    You can be the captain and I will draw the chart... Closer to the Heart
    Norco, CA WX: 89.7F, 44.0% humidity, 12 mph S wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Sat Jul 16 09:44:43 2022
    From Newsgroup: alt.bbs.synchronet

    On Saturday, July 16, 2022 at 1:40:50 AM UTC+3, Digital Man wrote:
    I'd go through the various sbup*.zip files in http://synchro.net/files/Main/SBBS_ARC/ and http://synchro.net/files/Main/SBBS/(starting with sbup300c.zip)

    And then finally (once you get to v3.19b), run 'jsexec update'.

    Hopefully that works for you (make/keep backups) and if you run into any problems, let us know and we'll help you out.
    So I did it. Found out that 3.10 installer will upgrade directly from 2.30, and from then on it was incremental, mostly manual upgrades to 3.19b.
    Up until 3.16 everything was good, after that I did not test every single version as I moved up. Finally, when starting 3.19b it the console it was complaining that it cannot open the configuration file from \sbbs\ctrl. I fired up scfg and found out that in the node path field there was some jibberish (random strings from who knows where). After cleaning these manually and saving from scfg the file was loaded fine. Telnet login works fine and everything seems to be in place. Only thing that is not working is HTTP access, I updated the web root to point to webv4, but when I try to access HTTP:\\localhost I get a 404 page.
    And to confirm, it was enough to run 'jsexec update' only once, after the 3.19b update or it should have been executed with every update?
    Thanks!
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Sat Jul 16 11:20:42 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Sat Jul 16 2022 11:44 am

    From Newsgroup: alt.bbs.synchronet

    On Saturday, July 16, 2022 at 1:40:50 AM UTC+3, Digital Man wrote:
    I'd go through the various sbup*.zip files in http://synchro.net/files/Main/SBBS_ARC/ and http://synchro.net/files/Main/SBBS/(starting with sbup300c.zip)

    And then finally (once you get to v3.19b), run 'jsexec update'.

    Hopefully that works for you (make/keep backups) and if you run into any problems, let us know and we'll help you out.
    So I did it. Found out that 3.10 installer will upgrade directly from 2.30, and from then on it was incremental, mostly manual upgrades to 3.19b.
    Up until 3.16 everything was good, after that I did not test every single version as I moved up. Finally, when starting 3.19b it the console it was complaining that it cannot open the configuration file from \sbbs\ctrl. I fired up scfg and found out that in the node path field there was some jibberish (random strings from who knows where).

    Interesting. I guess I should that 2.30->3.19 upgrade path myself with stock configs and see what the issue might be from.

    After cleaning these
    manually and saving from scfg the file was loaded fine. Telnet login works fine and everything seems to be in place. Only thing that is not working is HTTP access, I updated the web root to point to webv4, but when I try to access HTTP:\\localhost I get a 404 page.

    The log output of the web server should indicate what's the issue there.

    And to confirm, it was enough to run 'jsexec update' only once, after the 3.19b update or it should have been executed with every update?

    Running 'jsexec update' once should be enough.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #3:
    ASCII = American Standard Code for Information Interchange
    Norco, CA WX: 91.7F, 38.0% humidity, 11 mph SSW wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Sat Jul 16 12:00:09 2022
    From Newsgroup: alt.bbs.synchronet

    On Saturday, July 16, 2022 at 11:20:44 PM UTC+3, Digital Man wrote:

    version as I moved up. Finally, when starting 3.19b it the console it was complaining that it cannot open the configuration file from \sbbs\ctrl. I fired up scfg and found out that in the node path field there was some jibberish (random strings from who knows where).
    Interesting. I guess I should that 2.30->3.19 upgrade path myself with stock configs and see what the issue might be from.

    I'm planning to do it again but this time I'll grab some screenshots if I manage to reproduce it. Today was just quick & dirty run to get familiar with the process.

    fine and everything seems to be in place. Only thing that is not working is
    HTTP access, I updated the web root to point to webv4, but when I try to access HTTP:\\localhost I get a 404 page.
    The log output of the web server should indicate what's the issue there.

    If you mean the one in \sbbs\logs\ (http*.*), that one just contains the access timestamps, but I suspect there might be a more detailed log somewhere?

    I'll also install a fresh clean 3.19a install and compare the files between the two, especially in HTTP root folder.
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Sat Jul 16 15:48:00 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Sat Jul 16 2022 02:00 pm

    there was some jibberish (random strings from who knows where).
    Interesting. I guess I should that 2.30->3.19 upgrade path myself with stock configs and see what the issue might be from.

    I'm planning to do it again but this time I'll grab some screenshots if I manage to reproduce it. Today was just quick & dirty run to get familiar with the process.

    Yeah, I would expect any weirdness with odd values from the .cnf files (the settings/config-values shown in SCFG) to be present in earlier v3.x versions (too).

    fine and everything seems to be in place. Only thing that is not working is HTTP access, I updated the web root to point to webv4, but when I try to access HTTP:\\localhost I get a 404 page.
    The log output of the web server should indicate what's the issue there.

    If you mean the one in \sbbs\logs\ (http*.*), that one just contains the access timestamps, but I suspect there might be a more detailed log somewhere?

    Yes. If you're running the Synchronet Control Panel for Windows, then the web server log out goes to the "Web Server" tab (not a file).

    I'll also install a fresh clean 3.19a install and compare the files between the two, especially in HTTP root folder.

    Cool. Let me know what you discover.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #33:
    FSP = FidoNet Standards Proposal
    Norco, CA WX: 88.6F, 39.0% humidity, 12 mph SW wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Sun Jul 17 02:01:18 2022
    From Newsgroup: alt.bbs.synchronet

    On Sunday, July 17, 2022 at 3:47:58 AM UTC+3, Digital Man wrote:


    If you mean the one in \sbbs\logs\ (http*.*), that one just contains the access timestamps, but I suspect there might be a more detailed log somewhere?
    Yes. If you're running the Synchronet Control Panel for Windows, then the web server log out goes to the "Web Server" tab (not a file).

    Haven't had time today to do much, but here is the Web server log after trying to open a page:

    7/17 01:57:32p Synchronet Web Server Version 3.19b
    7/17 01:57:32p Compiled master/a2a9dc027 Jan 2 2022 16:02:20 with MSC 1928
    7/17 01:57:32p WinSock 2.0 Running
    7/17 01:57:32p Initializing on Sun Jul 17 13:57:32 2022 with options: 840
    7/17 01:57:32p Loading configuration files from c:\sbbs\ctrl\
    7/17 01:57:32p Temporary file directory: c:\sbbs\temp\
    7/17 01:57:32p Root directory: c:\sbbs\webv4\root
    7/17 01:57:32p Error directory: c:\sbbs\webv4\root\error\
    7/17 01:57:32p CGI directory: c:\sbbs\webv4\root\cgi-bin\
    7/17 01:57:32p Read 79 MIME types from root section of c:\sbbs\ctrl\mime_types.ini
    7/17 01:57:32p Read 1 CGI content handlers from CGI section of c:\sbbs\ctrl\web_handler.ini
    7/17 01:57:32p Read 1 JavaScript content handlers from JavaScript section of c:\sbbs\ctrl\web_handler.ini
    7/17 01:57:32p Web Server socket set created
    7/17 01:57:32p Web Server listening on socket 0.0.0.0 port 80
    7/17 01:57:32p HTTP logging thread started
    7/17 01:57:32p Web Server thread started
    7/17 01:57:42p 0908 HTTP connection accepted from: 127.0.0.1 port 49228
    7/17 01:57:42p 0908 Session thread started
    7/17 01:57:42p 0908 Autotuning outbuf highwater mark to 1460 based on MSS
    7/17 01:57:42p 0908 Request: GET / HTTP/1.1
    7/17 01:57:42p 0908 HTTP Logon (user #0)
    7/17 01:57:42p 0908 !ERROR: 404 Not Found (line 3721)
    7/17 01:57:42p 0908 Request resolved to: c:\sbbs\webv4\root\error\404.html
    7/17 01:57:42p 0908 Result: HTTP/1.1 404 Not Found
    7/17 01:57:42p HTTP logfile is now: c:\sbbs\DATA\logs/http-2022-07-17.log
    7/17 01:57:43p 0908 Session thread terminated (0 clients, 3 threads remain, 1 served)
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Sun Jul 17 20:19:47 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Sun Jul 17 2022 04:01 am

    From Newsgroup: alt.bbs.synchronet

    On Sunday, July 17, 2022 at 3:47:58 AM UTC+3, Digital Man wrote:


    If you mean the one in \sbbs\logs\ (http*.*), that one just contains the access timestamps, but I suspect there might be a more detailed log somewhere?
    Yes. If you're running the Synchronet Control Panel for Windows, then the web server log out goes to the "Web Server" tab (not a file).

    Haven't had time today to do much, but here is the Web server log after trying to open a page:

    7/17 01:57:32p Synchronet Web Server Version 3.19b
    7/17 01:57:32p Compiled master/a2a9dc027 Jan 2 2022 16:02:20 with MSC 1928
    7/17 01:57:32p WinSock 2.0 Running
    7/17 01:57:32p Initializing on Sun Jul 17 13:57:32 2022 with options: 840
    7/17 01:57:32p Loading configuration files from c:\sbbs\ctrl\
    7/17 01:57:32p Temporary file directory: c:\sbbs\temp\
    7/17 01:57:32p Root directory: c:\sbbs\webv4\root
    7/17 01:57:32p Error directory: c:\sbbs\webv4\root\error\
    7/17 01:57:32p CGI directory: c:\sbbs\webv4\root\cgi-bin\
    7/17 01:57:32p Read 79 MIME types from root section of c:\sbbs\ctrl\mime_types.ini
    7/17 01:57:32p Read 1 CGI content handlers from CGI section of c:\sbbs\ctrl\web_handler.ini
    7/17 01:57:32p Read 1 JavaScript content handlers from JavaScript section of c:\sbbs\ctrl\web_handler.ini
    7/17 01:57:32p Web Server socket set created
    7/17 01:57:32p Web Server listening on socket 0.0.0.0 port 80
    7/17 01:57:32p HTTP logging thread started
    7/17 01:57:32p Web Server thread started
    7/17 01:57:42p 0908 HTTP connection accepted from: 127.0.0.1 port 49228
    7/17 01:57:42p 0908 Session thread started
    7/17 01:57:42p 0908 Autotuning outbuf highwater mark to 1460 based on MSS
    7/17 01:57:42p 0908 Request: GET / HTTP/1.1
    7/17 01:57:42p 0908 HTTP Logon (user #0)
    7/17 01:57:42p 0908 !ERROR: 404 Not Found (line 3721)
    7/17 01:57:42p 0908 Request resolved to: c:\sbbs\webv4\root\error\404.html
    7/17 01:57:42p 0908 Result: HTTP/1.1 404 Not Found

    What is the [web] IndexFilesNames value in your ctrl/sbbs.ini file? It should include "index.xjs" and the webv4/root directory has an index.xjs file in it, yes?
    --
    digital man (rob)

    Rush quote #33:
    With the heart and mind united in a single, perfect sphere
    Norco, CA WX: 70.9F, 76.0% humidity, 0 mph ESE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Mon Jul 18 09:15:28 2022
    From Newsgroup: alt.bbs.synchronet

    On Monday, July 18, 2022 at 8:19:53 AM UTC+3, Digital Man wrote:
    7/17 01:57:42p 0908 Request: GET / HTTP/1.1
    7/17 01:57:42p 0908 HTTP Logon (user #0)
    7/17 01:57:42p 0908 !ERROR: 404 Not Found (line 3721)
    7/17 01:57:42p 0908 Request resolved to:
    c:\sbbs\webv4\root\error\404.html
    7/17 01:57:42p 0908 Result: HTTP/1.1 404 Not Found
    What is the [web] IndexFilesNames value in your ctrl/sbbs.ini file? It should include "index.xjs" and the webv4/root directory has an index.xjs file in it, yes?
    I've done the entire upgrade procedure again, but this time I am taking backups of every version and taking notes.
    Everything went well, some small hiccups, but if I carefully follow steps in readme file (and sometimes redo them), all seems well.
    I am on 3.17 now, so just a few steps left. webv4 was introduced in this version and I just realized that the web problem is present if I switch to webv4. If I set web root to web all is fine, so something seems to be missing in webv4 (and I noticed it is much smaller than web). (?)
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Mon Jul 18 09:20:11 2022
    From Newsgroup: alt.bbs.synchronet

    On Monday, July 18, 2022 at 8:19:53 AM UTC+3, Digital Man wrote:


    7/17 01:57:42p 0908 !ERROR: 404 Not Found (line 3721)
    7/17 01:57:42p 0908 Request resolved to:
    c:\sbbs\webv4\root\error\404.html
    7/17 01:57:42p 0908 Result: HTTP/1.1 404 Not Found
    What is the [web] IndexFilesNames value in your ctrl/sbbs.ini file? It should include "index.xjs" and the webv4/root directory has an index.xjs file in it, yes?

    Read you post again and found out that IndexFileName was pointing to index.html. I changed it to index.xjs and web root is set to ../webv4/root. File is there but I still get 404 error...hmmm...

    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Mon Jul 18 12:19:15 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Mon Jul 18 2022 11:20 am

    From Newsgroup: alt.bbs.synchronet

    On Monday, July 18, 2022 at 8:19:53 AM UTC+3, Digital Man wrote:


    7/17 01:57:42p 0908 !ERROR: 404 Not Found (line 3721)
    7/17 01:57:42p 0908 Request resolved to: c:\sbbs\webv4\root\error\404.html
    7/17 01:57:42p 0908 Result: HTTP/1.1 404 Not Found
    What is the [web] IndexFilesNames value in your ctrl/sbbs.ini file? It should include "index.xjs" and the webv4/root directory has an index.xjs file in it, yes?

    Read you post again and found out that IndexFileName was pointing to index.html. I changed it to index.xjs and web root is set to ../webv4/root. File is there but I still get 404 error...hmmm...

    The default IndexFileNames values is index.html,index.ssjs,index.xjs

    See https://gitlab.synchro.net/main/sbbs/-/blob/master/ctrl/sbbs.ini for reference. Perhaps you need 2 or more of those values for ecWeb to work.
    --
    digital man (rob)

    Sling Blade quote #22:
    Karl: I don't reckon you have to go with women to be a good father to a boy. Norco, CA WX: 91.6F, 23.0% humidity, 8 mph ESE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Tue Jul 19 05:52:21 2022
    From Newsgroup: alt.bbs.synchronet

    On Tuesday, July 19, 2022 at 12:19:21 AM UTC+3, Digital Man wrote:
    See https://gitlab.synchro.net/main/sbbs/-/blob/master/ctrl/sbbs.ini for reference. Perhaps you need 2 or more of those values for ecWeb to work.
    Thanks, I will revisit the web thing and play around with it, I already see that the configuration file on gitlab has more settings than mine.
    However, I managed to reproduce the problem I had initially, and it is triggered by the upgrade from 3.18 to 3.19a. After starting Synchronet it complains that it cannot open the configuration file, and when opening scfg I see garbled strings in each node path field. If I clean it up manually the service will start, but I'm wondering if something else could be messed up in cfg file (?) If you need any info that may help let me know, but it seems it is reproducible.
    Screenshot here:
    https://photos.app.goo.gl/wZufzgzdNbBRVms37
    Thanks!
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Tue Jul 19 08:59:10 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Tue Jul 19 2022 07:52 am

    From Newsgroup: alt.bbs.synchronet

    On Tuesday, July 19, 2022 at 12:19:21 AM UTC+3, Digital Man wrote:
    See https://gitlab.synchro.net/main/sbbs/-/blob/master/ctrl/sbbs.ini for reference. Perhaps you need 2 or more of those values for ecWeb to work.
    Thanks, I will revisit the web thing and play around with it, I already see that the configuration file on gitlab has more settings than mine.
    However, I managed to reproduce the problem I had initially, and it is triggered by the upgrade from 3.18 to 3.19a. After starting Synchronet it complains that it cannot open the configuration file, and when opening scfg I see garbled strings in each node path field. If I clean it up manually the service will start, but I'm wondering if something else could be messed up in cfg file (?) If you need any info that may help let me know, but it seems it is reproducible.
    Screenshot here:
    https://photos.app.goo.gl/wZufzgzdNbBRVms37

    No one else has reported that issue, so it is intersting. I'll try a v2.30->v3.19 upgrade path at some point and see if I can reproduce it.

    .ini files with "more settings" is fine (you don't need to add them), the default values are used in that case.
    --
    digital man (rob)

    Synchronet "Real Fact" #98:
    Synchronet v3.12a was released on December 31st of 2004 (Rob's birthday)
    Norco, CA WX: 85.2F, 35.0% humidity, 1 mph E wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From MRO@VERT/BBSESINF to Riba on Tue Jul 19 14:12:21 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Tue Jul 19 2022 07:52 am

    I see garbled strings in each node path field. If I clean it up manually the service will start, but I'm wondering if something else could be messed up in cfg file (?) If you need any info that may help let me know, but it seems it is reproducible.
    Screenshot here:
    https://photos.app.goo.gl/wZufzgzdNbBRVms37
    Thanks!

    holy shit that's not good.

    how about do it this way.

    put up a whole new stock bbs, make a backup and do some transplantation.
    copy over and re-setup yourdoorgames
    copy over and set up your old command shell in sfg
    re-setup your msg and file areas.

    how customized was your bbs and what are you okay with redoing?
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From Riba@VERT to alt.bbs.synchronet on Wed Jul 20 02:46:30 2022
    From Newsgroup: alt.bbs.synchronet

    On Wednesday, July 20, 2022 at 12:16:14 AM UTC+3, MRO wrote:


    how about do it this way.

    put up a whole new stock bbs, make a backup and do some transplantation. copy over and re-setup yourdoorgames
    copy over and set up your old command shell in sfg
    re-setup your msg and file areas.

    how customized was your bbs and what are you okay with redoing?

    Very customized. :) But I'm not too concerned, if I clean up node path fields then it starts up fine and appears to run fine. I will test it a bit more but if everything checks out ok I guess that is only a glitch that can be sorted out manually.
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Wed Jul 20 06:52:32 2022
    From Newsgroup: alt.bbs.synchronet

    On Tuesday, July 19, 2022 at 8:59:17 PM UTC+3, Digital Man wrote:

    I see garbled strings in each node path field. If I clean it up manually the
    service will start, but I'm wondering if something else could be messed up in cfg file (?) If you need any info that may help let me know, but it seems
    it is reproducible.
    Screenshot here:
    https://photos.app.goo.gl/wZufzgzdNbBRVms37
    No one else has reported that issue, so it is intersting. I'll try a v2.30->v3.19 upgrade path at some point and see if I can reproduce it.

    .ini files with "more settings" is fine (you don't need to add them), the default values are used in that case.

    Ok, almost there. Now i get error 500 when accessing the web page, the error reported in the log is:

    0376 Error: Guest account unavailable

    I suspect I need to enable guest account somewhere (?)
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Riba on Wed Jul 20 10:18:32 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Wed Jul 20 2022 08:52 am

    Ok, almost there. Now i get error 500 when accessing the web page, the error reported in the log is:

    0376 Error: Guest account unavailable

    I suspect I need to enable guest account somewhere (?)

    During you Synchronet setup, the first time you log in as a sysop, you should be asked if you want to create a guest account. If you're past that already, you should be able to create the guest account using the makeguest module:

    http://wiki.synchro.net/module:makeguest

    http://wiki.synchro.net/install:setup


    (By the way, the Synchronet wiki can be a good resource for questions like this, so you don't have to ask and wait for someone to answer.)

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Phigan@VERT/TACOPRON to Nightfox on Wed Jul 20 17:46:26 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Nightfox to Riba on Wed Jul 20 2022 12:18 pm

    should be asked if you want to create a guest account. If you're past that already, you should be able to create the guest account using the makeguest module:

    What's the best way to disable the guest account? Remove that module?

    ---
    Synchronet TIRED of waiting 2 hours for a taco? GO TO TACOPRONTO.bbs.io
  • From Digital Man@VERT to Riba on Wed Jul 20 11:06:02 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Wed Jul 20 2022 08:52 am

    From Newsgroup: alt.bbs.synchronet

    On Tuesday, July 19, 2022 at 8:59:17 PM UTC+3, Digital Man wrote:

    I see garbled strings in each node path field. If I clean it up manually the
    service will start, but I'm wondering if something else could be messed up in cfg file (?) If you need any info that may help let me know, but it seems
    it is reproducible.
    Screenshot here:
    https://photos.app.goo.gl/wZufzgzdNbBRVms37
    No one else has reported that issue, so it is intersting. I'll try a v2.30->v3.19 upgrade path at some point and see if I can reproduce it.

    .ini files with "more settings" is fine (you don't need to add them), the default values are used in that case.

    Ok, almost there. Now i get error 500 when accessing the web page, the error reported in the log is:

    0376 Error: Guest account unavailable

    I suspect I need to enable guest account somewhere (?)

    Yes, ecWeb requires a guest account.
    --
    digital man (rob)

    Synchronet "Real Fact" #97:
    Synchronet v3.13a was released in September of 2005 (9 months after v3.12a) Norco, CA WX: 88.5F, 30.0% humidity, 3 mph E wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Phigan on Wed Jul 20 11:06:57 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Phigan to Nightfox on Wed Jul 20 2022 07:46 pm

    Re: Re: Upgrading from 2.30 to 3.19b
    By: Nightfox to Riba on Wed Jul 20 2022 12:18 pm

    should be asked if you want to create a guest account. If you're past that already, you should be able to create the guest account using the makeguest module:

    What's the best way to disable the guest account? Remove that module?

    Delete or deactivate the "Guest" user if you wish. No module needs to be removed.
    --
    digital man (rob)

    This Is Spinal Tap quote #41:
    Ian Faith: It say's "Memphis show cancelled due to lack of advertising funds." Norco, CA WX: 88.5F, 30.0% humidity, 3 mph E wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From MRO@VERT/BBSESINF to Riba on Wed Jul 20 13:28:04 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Wed Jul 20 2022 04:46 am

    From Newsgroup: alt.bbs.synchronet

    On Wednesday, July 20, 2022 at 12:16:14 AM UTC+3, MRO wrote:


    how about do it this way.

    put up a whole new stock bbs, make a backup and do some

    transplantation.
    copy over and re-setup yourdoorgames
    copy over and set up your old command shell in sfg
    re-setup your msg and file areas.

    how customized was your bbs and what are you okay with redoing?

    Very customized. :) But I'm not too concerned, if I clean up node path fields then it starts up fine and appears to run fine. I will test it a bit more but if everything checks out ok I guess that is only a glitch that can be sorted out manually.

    if you want to zip it up and send it to me i can play with it. delete your user.dat file and anything else. if you redo your borked fields and it runs fine, that's good enough though.

    make sure your events run. with the new changes you need to change some settings so they run.
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From MRO@VERT/BBSESINF to Phigan on Wed Jul 20 13:28:55 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Phigan to Nightfox on Wed Jul 20 2022 07:46 pm

    Re: Re: Upgrading from 2.30 to 3.19b
    By: Nightfox to Riba on Wed Jul 20 2022 12:18 pm

    should be asked if you want to create a guest account. If you're past that already, you should be able to create the guest account using the makeguest module:

    What's the best way to disable the guest account? Remove that module?

    you can just not have one. or you can make a guest account and give it a password and change the access around.
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From Nightfox@VERT/DIGDIST to Phigan on Wed Jul 20 14:41:26 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Phigan to Nightfox on Wed Jul 20 2022 07:46 pm

    What's the best way to disable the guest account? Remove that module?

    Removing that module would have no effect on the guest account.
    I thought there was a toggle somewhere to disable the guest account, but now I don't know for sure how to disable it.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Phigan@VERT/TACOPRON to Nightfox on Wed Jul 20 22:51:20 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Nightfox to Phigan on Wed Jul 20 2022 04:41 pm

    I thought there was a toggle somewhere to disable the guest account, but now

    I think I found it in a .ini file in the ctrl directory. I set it to false, but forgot to check it after restarting :). I'll go check that now.

    ---
    Synchronet TIRED of waiting 2 hours for a taco? GO TO TACOPRONTO.bbs.io
  • From Gamgee@VERT/PALANT to Nightfox on Wed Jul 20 17:47:00 2022
    Nightfox wrote to Phigan <=-

    What's the best way to disable the guest account? Remove that module?

    Removing that module would have no effect on the guest account.
    I thought there was a toggle somewhere to disable the guest
    account, but now I don't know for sure how to disable it.

    I think it would be done with the ';UEDIT' command (as Sysop from the
    main menu), should be User #2, and then use the 'D' command.



    ... Auntie Em, Hate Kansas, Hate You, Taking the dog...Dorothy
    --- MultiMail/Linux v0.52
    Synchronet Palantir BBS * palantirbbs.ddns.net * Pensacola, FL
  • From Nightfox@VERT/DIGDIST to Gamgee on Wed Jul 20 17:26:10 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Gamgee to Nightfox on Wed Jul 20 2022 07:47 pm

    Removing that module would have no effect on the guest account.
    I thought there was a toggle somewhere to disable the guest
    account, but now I don't know for sure how to disable it.

    I think it would be done with the ';UEDIT' command (as Sysop from the main menu), should be User #2, and then use the 'D' command.

    Makes sense that just deleting the guest account should work.

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Riba@VERT to alt.bbs.synchronet on Wed Jul 20 23:02:25 2022
    From Newsgroup: alt.bbs.synchronet

    On Wednesday, July 20, 2022 at 10:29:38 PM UTC+3, Nightfox wrote:
    To: Riba
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Wed Jul 20 2022 08:52 am

    Ok, almost there. Now i get error 500 when accessing the web page, the error reported in the log is:

    0376 Error: Guest account unavailable

    I suspect I need to enable guest account somewhere (?)

    During you Synchronet setup, the first time you log in as a sysop, you should be asked if you want to create a guest account. If you're past that already, you should be able to create the guest account using the makeguest module:

    http://wiki.synchro.net/module:makeguest

    http://wiki.synchro.net/install:setup


    (By the way, the Synchronet wiki can be a good resource for questions like this, so you don't have to ask and wait for someone to answer.)


    Thanks, that did the trick, everything seems to run without errors now. I'll dive into the wiki now to avoid wasting other people time. Now comes the scary part of facing the past. :-D
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Thu Jul 21 10:00:38 2022
    From Newsgroup: alt.bbs.synchronet

    Another issue, telnet login from web is not working, browser console reports following:

    ftelnet.norip.noxfer.min.js?v=2019-08-31:370 Uncaught DOMException: Failed to construct 'WebSocket': The URL 'ws://192.168.8.172:-1' is invalid.
    at WebSocketConnection.connect (http://embed-v2.ftelnet.ca/ftelnet/ftelnet.norip.noxfer.min.js?v=2019-08-31:370:85)
    at fTelnetClient.Connect (http://embed-v2.ftelnet.ca/ftelnet/ftelnet.norip.noxfer.min.js?v=2019-08-31:475:277)
    at HTMLButtonElement.<anonymous> (http://192.168.8.172/?page=000-home.xjs:138:15)
    at HTMLButtonElement.dispatch (http://192.168.8.172/js/jquery.min.js:4:8549)
    at r.handle (http://192.168.8.172/js/jquery.min.js:4:5252)

    Any tips? Hopefully not something I have missed in the wiki. :-/
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Nightfox@VERT/DIGDIST to Riba on Thu Jul 21 12:13:13 2022
    Re: Re: Upgrading from 2.30 to 3.19b
    By: Riba to alt.bbs.synchronet on Thu Jul 21 2022 12:00 pm

    ftelnet.norip.noxfer.min.js?v=2019-08-31:370 Uncaught DOMException: Failed to construct 'WebSocket': The URL 'ws://192.168.8.172:-1' is invalid.

    It looks like it's trying to use -1 as the port number for the web socket port. I don't think -1 is a valid port number.

    There's a section on the Synchronet wiki about getting fTelnet to work, and you have to make sure to specify the right configuration in ctrl/services.ini for websocketservice.js:

    http://wiki.synchro.net/config:webv4

    The wiki includes ports 1123 and 11235. In mine, I have those, plus 4142 (though I'm wondering if the 4142 in my configuration may be leftover from an old configuration which I might not need anymore).

    Nightfox

    ---
    Synchronet Digital Distortion: digitaldistortionbbs.com
  • From Riba@VERT to alt.bbs.synchronet on Fri Jul 22 02:05:56 2022
    From Newsgroup: alt.bbs.synchronet

    On Friday, July 22, 2022 at 12:29:48 AM UTC+3, Nightfox wrote:

    ftelnet.norip.noxfer.min.js?v=2019-08-31:370 Uncaught DOMException: Failed
    to construct 'WebSocket': The URL 'ws://192.168.8.172:-1' is invalid.

    It looks like it's trying to use -1 as the port number for the web socket port. I don't think -1 is a valid port number.

    There's a section on the Synchronet wiki about getting fTelnet to work, and you have to make sure to specify the right configuration in ctrl/services.ini for websocketservice.js:

    http://wiki.synchro.net/config:webv4

    The wiki includes ports 1123 and 11235. In mine, I have those, plus 4142 (though I'm wondering if the 4142 in my configuration may be leftover from an old configuration which I might not need anymore).
    Nightfox

    Thanks, that did it! Entire [WS] configuration part was missing in my services.ini file, after adding it telnet through web is working. Thanks to everyone for all the help and patience!

    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net