• Timed Events..

    From Bucko@VERT/WN2 to All on Wed Nov 9 18:48:51 2022
    Got a weird one happening. I am running 3.19b as a Door Server and my Timed Events don't work anymore I can't force them and all they do is return a 255 result code in the error log. I am know I am being vague, but where can I start to look first, I have run the files in question from a command prompt and they run with no issues. Basically, the files in question are Tradewars auto maints which ran with no issues on 3.18, I know the events work with 3.19 as I am running 3.19c as a BBS and everything works.. Anyone have ideas where I can start with this??

    ---
    Synchronet The Wrong Number Family Of BBS' - Bucko's Den
  • From MRO@VERT/BBSESINF to Bucko on Wed Nov 9 22:55:51 2022
    Re: Timed Events..
    By: Bucko to All on Wed Nov 09 2022 06:48 pm

    Got a weird one happening. I am running 3.19b as a Door Server and my Timed Events don't work anymore I can't force them and all they do is return a 255 result code in the error log. I am know I am being vague, but where can I start to look first, I have run the files in question from a command prompt and they run with no issues. Basically, the files in question are Tradewars auto maints which ran with no issues on 3.18, I know the events work with 3.19 as I am running 3.19c as a BBS and everything works.. Anyone have ideas where I can start with this??


    post the config setting for one of your events from scfg
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From Digital Man@VERT to Bucko on Thu Nov 10 10:53:47 2022
    Re: Timed Events..
    By: Bucko to All on Wed Nov 09 2022 06:48 pm

    Got a weird one happening. I am running 3.19b as a Door Server and my Timed Events don't work anymore I can't force them and all they do is return a 255 result code in the error log.

    A "255 result code in the error log" sounds like the Synchronet even thread is running and its attempting to run the events. If you try to force an event to run, do you see new activity in the event thread log output or a new error?

    I am know I am being vague, but where can I
    start to look first, I have run the files in question from a command prompt and they run with no issues. Basically, the files in question are Tradewars auto maints which ran with no issues on 3.18, I know the events work with 3.19 as I am running 3.19c as a BBS and everything works.. Anyone have ideas where I can start with this??

    I'm assuming the Tradewars maintence is a 16-bit DOS program. Do native 32-bit Windows events run okay? It'd be good to isolate which *kinds* of events you're having problems with. If only 16-bit DOS events are failing, then that would start to indicate a problem with NTVDM (assuming we're talking about a Windows version of Synchronet here) - is this a 32-bit Windows install or are you using NTVDMx64?

    The pasted output of your event log would help too.
    --
    digital man (rob)

    This Is Spinal Tap quote #18:
    Sustain, listen to it. Don't hear anything. You would though were it playing. Norco, CA WX: 63.7F, 40.0% humidity, 0 mph ESE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Al DeRosa@VERT to Digital Man on Thu Nov 10 18:48:01 2022
    On 10 Nov 2022, Digital Man said the following...


    A "255 result code in the error log" sounds like the Synchronet even thread is running and its attempting to run the events. If you try to force an event to run, do you see new activity in the event thread log output or a new error?

    I see a new error every time I try to force a event to run.


    I'm assuming the Tradewars maintence is a 16-bit DOS program. Do native 32-bit Windows events run okay? It'd be good to isolate which *kinds* of events you're having problems with. If only 16-bit DOS events are
    failing, then that would start to indicate a problem with NTVDM
    (assuming we're talking about a Windows version of Synchronet here) - is this a 32-bit Windows install or are you using NTVDMx64?


    I am running 16 bit maint progams on a 32 bit Windows Install, I just tried to force a AVAT in and see nothing on the services window, or Terminal Server window of it running.

    The pasted output of your event log would help too.
    --
    digital man (rob)

    Here is the end of it, nothing about AVAT-IN being run and this is the results of the maint files trying to run..

    Thu Nov 10 00:00:00 2022 master/a2a9dc027
    evnt GO Timed event: GO returned 255

    Thu Nov 10 00:01:00 2022 master/a2a9dc027
    evnt TJLOTTOM Timed event: TJLOTTOM returned 255

    Thu Nov 10 00:15:00 2022 master/a2a9dc027
    evnt TWARAM Timed event: TWARAM returned 255

    Thu Nov 10 00:15:00 2022 master/a2a9dc027
    evnt TW3MAINT Timed event: TW3MAINT returned 255

    Thu Nov 10 02:00:00 2022 master/a2a9dc027
    evnt TW2MAINT Timed event: TW2MAINT returned 255

    Is it possible the event services aren't running? This set up is a 3.19b which was installed from scratch then a migration from a 3.18 system took place
    after I upgraded that system to 3.19b. Thanks for the help..

    AL

    ... Top secret! Burn before reading!

    --- Mystic BBS v1.12 A48 2022/07/15 (Linux/64)
    * Origin: The Wrong Number Family Of BBS' - Wrong Number ][ (1:267/157)
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Al DeRosa@VERT to Digital Man on Thu Nov 10 18:52:51 2022
    Just as an add on, I just added the Events window and AVAT-IN worked. When I force say the Tradewars even it shows Semaphore signaled for Timed event. It says it is running it, and then it returns the 255. This is a new Windows 10 install from last month.. Wondering if it is a Windows issue instead even though I can run the files a DOS prompt...

    ... Redundant book title: DOS For Dummies

    --- Mystic BBS v1.12 A48 2022/07/15 (Linux/64)
    * Origin: The Wrong Number Family Of BBS' - Wrong Number ][ (1:267/157)
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Al DeRosa@VERT to Digital Man on Thu Nov 10 19:01:53 2022
    I figured it out... On my original system I had these Timed Events with the Native Executable flag as NO, I just changed them all on the new system to YES and they all work now. It seems to work now so I am happy.. LOL Thanks to You Rob and MRO for helping out...
    AL

    ... Old computers make great boat anchors

    --- Mystic BBS v1.12 A48 2022/07/15 (Linux/64)
    * Origin: The Wrong Number Family Of BBS' - Wrong Number ][ (1:267/157)
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Al DeRosa on Thu Nov 10 17:30:57 2022
    Re: Re: Timed Events..
    By: Al DeRosa to Digital Man on Thu Nov 10 2022 06:48 pm

    On 10 Nov 2022, Digital Man said the following...


    A "255 result code in the error log" sounds like the Synchronet even thread is running and its attempting to run the events. If you try to force an event to run, do you see new activity in the event thread log output or a new error?

    I see a new error every time I try to force a event to run.


    I'm assuming the Tradewars maintence is a 16-bit DOS program. Do native 32-bit Windows events run okay? It'd be good to isolate which *kinds* of events you're having problems with. If only 16-bit DOS events are failing, then that would start to indicate a problem with NTVDM (assuming we're talking about a Windows version of Synchronet here) - is this a 32-bit Windows install or are you using NTVDMx64?


    I am running 16 bit maint progams on a 32 bit Windows Install, I just tried to force a AVAT in and see nothing on the services window, or Terminal Server window of it running.

    Timed events are logged in the "Events" window of SBBSCTRL.

    The pasted output of your event log would help too.

    Here is the end of it, nothing about AVAT-IN being run and this is the results of the maint files trying to run..

    Thu Nov 10 00:00:00 2022 master/a2a9dc027
    evnt GO Timed event: GO returned 255

    Thu Nov 10 00:01:00 2022 master/a2a9dc027
    evnt TJLOTTOM Timed event: TJLOTTOM returned 255

    Thu Nov 10 00:15:00 2022 master/a2a9dc027
    evnt TWARAM Timed event: TWARAM returned 255

    Thu Nov 10 00:15:00 2022 master/a2a9dc027
    evnt TW3MAINT Timed event: TW3MAINT returned 255

    Thu Nov 10 02:00:00 2022 master/a2a9dc027
    evnt TW2MAINT Timed event: TW2MAINT returned 255

    Is it possible the event services aren't running?

    Not sure what an "event services" is. The event *thread* is running or else you wouldn't be seeing these errors.

    This set up is a 3.19b
    which was installed from scratch then a migration from a 3.18 system took place
    after I upgraded that system to 3.19b. Thanks for the help..

    No matter. So are only 16-bit DOS programs failing? Do 16-bit DOS programs run successfully as doors on that same BBS?
    --
    digital man (rob)

    Synchronet "Real Fact" #122:
    Synchronet v2.30a (DOS & OS/2) was released on 5-30-97, 20 months after v2.20b Norco, CA WX: 59.6F, 53.0% humidity, 0 mph SSE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Al DeRosa on Thu Nov 10 17:32:47 2022
    Re: Re: Timed Events..
    By: Al DeRosa to Digital Man on Thu Nov 10 2022 06:52 pm

    Just as an add on, I just added the Events window and AVAT-IN worked. When I force say the Tradewars even it shows Semaphore signaled for Timed event. It says it is running it, and then it returns the 255. This is a new Windows 10 install from last month.. Wondering if it is a Windows issue instead even though I can run the files a DOS prompt...

    Did you install Synchronet or just copy it over from some other install? If you just copied it, perhaps you forgot to copy sbbsexec.dll to the Windows\System32 directory?
    https://wiki.synchro.net/faq:win
    --
    digital man (rob)

    Rush quote #39:
    Sounds that build high like a mountain or notes that fall, gently, like rain Norco, CA WX: 59.6F, 53.0% humidity, 0 mph SSE wind, 0.00 inches rain/24hrs ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From MRO@VERT/BBSESINF to Al DeRosa on Thu Nov 10 19:06:54 2022
    Re: Re: Timed Events..
    By: Al DeRosa to Digital Man on Thu Nov 10 2022 07:01 pm

    I figured it out... On my original system I had these Timed Events with the Native Executable flag as NO, I just changed them all on the new system to YES and they all work now. It seems to work now so I am happy.. LOL Thanks to You Rob and MRO for helping out...
    AL



    that's why i said to post the config

    when you do an update from an older version you have to change that.
    that's what happened to daryl and me.
    ---
    Synchronet ::: BBSES.info - free BBS services :::
  • From Al DeRosa@VERT to MRO on Fri Nov 11 15:40:39 2022
    On 10 Nov 2022, MRO said the following...


    that's why i said to post the config

    when you do an update from an older version you have to change that. that's what happened to daryl and me.
    ---

    LOL I knew it would be something minor. Thank you again for the help.. Checked my events from last night and they ran with no issues.. :)

    ... Reward for a job well done: More work

    --- Mystic BBS v1.12 A48 2022/07/15 (Linux/64)
    * Origin: The Wrong Number Family Of BBS' - Wrong Number ][ (1:267/157)
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net