• Splash screen in web telnet window?

    From Riba@VERT to alt.bbs.synchronet on Sun Jul 24 05:23:31 2022
    From Newsgroup: alt.bbs.synchronet

    Need some help with changing the default splash screen in telnet window on the web interface.

    According to wiki, by default it points to ../text/synch.asc

    I tried both replacing the synch.asc with my modified file (did not change on web page), and also adding:

    [web]
    ftelnet_splash = ../text/tvri.ans
    (also tried ..\text\tvri.ans as it is a Windows host)

    ...but the moment I add this change to ..\ctrl\modopts.ini the web server throws an error:

    !JavaScript c:\sbbs\webv4\root\index.xjs.ssjs line 6: Error: can't open undefined/lib/init.js: No such file or directory

    Removing the lines fixes it. So how can I change this splash screen and if the default file/location is correct how come editing the file does nothing?

    Thanks!
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From DesotoFireflite@VERT/VALHALLA to Riba on Sun Jul 24 11:05:03 2022
    Re: Splash screen in web telnet window?
    By: Riba to alt.bbs.synchronet on Sun Jul 24 2022 07:23 am

    From Newsgroup: alt.bbs.synchronet

    Need some help with changing the default splash screen in telnet window on the web interface.


    According to wiki, by default it points to ../text/synch.asc

    First of all, does it work with the default screen named "../text/synch.ans"

    ; Path to a .ans file to use as the ftelnet splash screen
    ftelnet_splash=../text/synch.ans


    I tried both replacing the synch.asc with my modified file (did not change on web page), and also adding:

    [web]
    ftelnet_splash = ../text/tvri.ans
    (also tried ..\text\tvri.ans as it is a Windows host)

    Did you shut down the web page, then reopen it with the new default everytime you made a change. This has to be done.

    Also, did you try renaming your ansi file to splash.ans. You should not have to, but it's worth a shot to narrow down a problem. I'm running two spash screens over here, and the sring works. ( that requires some modding however)

    ...but the moment I add this change to ..\ctrl\modopts.ini the web server throws an error:

    !JavaScript c:\sbbs\webv4\root\index.xjs.ssjs line 6: Error: can't open undefined/lib/init.js: No such file or directory

    I think that is due to changing the default without restating your browser. I found out the hard way, webv4 needs to be restarted (closed, then reopened) before changes will work.

    Removing the lines fixes it. So how can I change this splash screen and if the default file/location is correct how come editing the file does nothing?

    try shutting down the the web page in your browser, then going back into it.

    SysOp: C.G. Learn, AKA: DesotoFireflite
    Valhalla Home Services! - (Synchronet) - bbs.valhallabbs.com:23
    A Gamers Paradise - Over 250 Registered Online Game Doors!

    --- Don't eat the yellow snow!
    Synchronet Valhalla Home Services USA http://valhalla.synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Sun Jul 24 10:53:09 2022
    From Newsgroup: alt.bbs.synchronet

    On Sunday, July 24, 2022 at 8:22:25 PM UTC+3, DesotoFireflite wrote:


    Need some help with changing the default splash screen in telnet window on
    the web interface.

    According to wiki, by default it points to ../text/synch.asc

    First of all, does it work with the default screen named "../text/synch.ans"

    ; Path to a .ans file to use as the ftelnet splash screen ftelnet_splash=../text/synch.ans

    Just tested that, no, the moment I add this and restart the web server it spits an error in the log:
    7/24 09:41:21p 1204 !JavaScript c:\sbbs\webv4\root\api\events.ssjs line 3: Error: can't open undefined/lib/init.js: No such file or directory, Request: /api/events.ssjs?subscribe=nodelist&subscribe=mail&subscribe=telegram

    I tried both replacing the synch.asc with my modified file (did not change
    on web page), and also adding:

    [web]
    ftelnet_splash = ../text/tvri.ans
    (also tried ..\text\tvri.ans as it is a Windows host)

    Did you shut down the web page, then reopen it with the new default everytime you made a change. This has to be done.

    Yes, I restarted the web service and entire Synchronet between changes.

    Also, did you try renaming your ansi file to splash.ans. You should not have to, but it's worth a shot to narrow down a problem. I'm running two spash screens over here, and the sring works. ( that requires some modding however)

    Tried, no luck. I'm pretty sure that it doesn't seem to be reading the ..\text\synch.ans file at all, because if I rename it it still displays the same content in the telnet window (?)

    ...but the moment I add this change to ..\ctrl\modopts.ini the web server
    throws an error:

    !JavaScript c:\sbbs\webv4\root\index.xjs.ssjs line 6: Error: can't open undefined/lib/init.js: No such file or directory

    I think that is due to changing the default without restating your browser. I found out the hard way, webv4 needs to be restarted (closed, then reopened) before changes will work.

    I did restart it after each change. :(

    Removing the lines fixes it. So how can I change this splash screen and if
    the default file/location is correct how come editing the file does nothing?

    try shutting down the the web page in your browser, then going back into it.

    Tried that as well, including clearing the browser cache. I'm completely at loss here.
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Riba on Sun Jul 24 12:40:08 2022
    Re: Splash screen in web telnet window?
    By: Riba to alt.bbs.synchronet on Sun Jul 24 2022 07:23 am

    From Newsgroup: alt.bbs.synchronet

    Need some help with changing the default splash screen in telnet window on the web interface.

    According to wiki, by default it points to ../text/synch.asc

    I tried both replacing the synch.asc with my modified file (did not change on web page), and also adding:

    [web]
    ftelnet_splash = ../text/tvri.ans
    (also tried ..\text\tvri.ans as it is a Windows host)

    ...but the moment I add this change to ..\ctrl\modopts.ini the web server throws an error:

    !JavaScript c:\sbbs\webv4\root\index.xjs.ssjs line 6: Error: can't open undefined/lib/init.js: No such file or directory

    Do you have the the "web_directory" key set in the [web] section of modopts.ini? Compare you settings to the stock modopts.ini.

    Removing the lines fixes it. So how can I change this splash screen and if the default file/location is correct how come editing the file does nothing?

    There's also a default base64-encoded splash screen defined in webv4/lib/ftelnet.js, perhaps that's where it's coming from.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #22:
    DOCSIS = Data Over Cable Service Interface Specification
    Norco, CA WX: 85.9F, 50.0% humidity, 11 mph S wind, 0.00 inches rain/24hrs
    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Riba@VERT to alt.bbs.synchronet on Sun Jul 24 22:56:20 2022
    From Newsgroup: alt.bbs.synchronet

    On Monday, July 25, 2022 at 12:40:13 AM UTC+3, Digital Man wrote:


    [web]
    ftelnet_splash = ../text/tvri.ans
    (also tried ..\text\tvri.ans as it is a Windows host)

    ...but the moment I add this change to ..\ctrl\modopts.ini the web server throws an error:

    !JavaScript c:\sbbs\webv4\root\index.xjs.ssjs line 6: Error: can't open undefined/lib/init.js: No such file or directory
    Do you have the the "web_directory" key set in the [web] section of modopts.ini? Compare you settings to the stock modopts.ini.

    Thanks, added a bunch of options from example modopts.ini and it worked like a charm.

    Removing the lines fixes it. So how can I change this splash screen and if the default file/location is correct how come editing the file does nothing?
    There's also a default base64-encoded splash screen defined in webv4/lib/ftelnet.js, perhaps that's where it's coming from.

    Mystery solved then. :) I guess without any options set in modopts.ini it will default to that one.
    --- Synchronet 3.19c-Linux NewsLink 1.113
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net